Thinkpads

Version: 

Section: 

Hardware

This document was created from testing notes on MX-15 Beta 2 during development by user hierax_ca--much appreciated!

600x (2645-5FU) 2000-01 (CPU: P3-650MHz, RAM: 576MB, VRAM:4MB)

  • Notes: Works, but just barely (not surprising since barely meets minimum specs for MX), slow + some app crashes (might be due to primitive CPU), suspend failed, = MX possible but not recommended on computer this old (tried it just to see if it would work), works better than AntiX-15v because no graphics recoloring skewing issue, it flies on DOS/Win9x, so use it for that kinda retro-computing gaming, just keep off internet. On 850MHz modified model MX-14.4 works but not MX-15.b2, not sure why, might be something with the modification for the non-standard CPU (like how Win2k sometimes has issues not recognizing the extra +200MHz).

A31p (2653-R4U) 2003-06 (CPU: P4m-2.0GHz, RAM:2GB, VRAM:64MB)

  • Notes: Works very well with either 160gb HDD or 16gb/128gb mSATA with Aleratec adapter! Wireless need to upgrade card to fast “n” (may require BIOS mod like did for T43p) to get better speeds, but fully works with wired. Need to figure out how to get Linux to recognize the awesome special side internet keys to recognize apps. = great baseline computer for MX-15, meets recommended specs and works well, with it's still amazing screen will be a great internet computer once the wireless card is upgraded and internet buttons are figured out, already an excellent word-processing workstation with the screen and keyboard. Can pretty much use this inter-changeably swapping with Win2K for legacy apps that won't work through Linux Wine/Play on Linux (still need to test these).

T43pFS (2668-Q6U) 2006 (CPU:P4m-2.26GHz, RAM:2GB RAM, VRAM:128MB)

  • Notes: - Works great, very much like A31p but faster (must be CPU, GPU/VRAM, SSD) only downside is lack of special side internet buttons. Keyboard and screen still obliterate modern computers for word-processing and DTP. Note: this one uses non-Stock Hardware: SATA Modified Motherboard, uber- SLC SSD from Intel and Micron, Wireless Card (AR922X) with BIOS mod common to Thinkpad connoisseurs – will try stock model with 320gb HDD and regular wireless card to see after MX15-RC1 (or maybe just use the non- FrankenPadish ones for WinXP legacy stuff). After RC1 need to remember to test with all the extra weird peripherals (zip drive, superdisk, etc.). This was the computer I wanted to get working on the internet again (not safe for WinXP anymore, and slightly too slow for Win7 with only 2gb RAM) and to try out Linux to see if it could do it and MX-14.4 and MX-15.b2 have convinced me that this is a viable long-term solution to getting more life out of this computer and then can unwrap the mint condition one once this one dies and hopefully go onto Debian 9 “Stretch” MX-16 to keep a dinosaur alive and useful into the far future...

t601pF (8890-A96*) 2007-05 (CPU: Core2 Duo T9300 2.5GHz, RAM: 8GB RAM, VRAM:256MB)

  • Notes: Works great like A31p and T43p but much faster with Dual Core CPU, 4x RAM, 2x-4x VRAM, and native SATA (not adapter like A31p or hybrid like T43p)! *Customized “FrankenPad” hardware not stock t61p (t61p motherboard in t60p body) also upgrade wireless card. Ultimate 4:3 workstation 1600x1200 is unmatched by modern systems for actually getting work done (only W500/W700/W701 are arguably comparable). Transitional computer so not sure about using 32-bit or 64-bit MX-15 with this, compare how it works under RC- 1...

x61t (7769-A53) 2008-04 (CPU: Core2 Duo L7500 1.6GHz, RAM: 8GB, VRAM:?)

  • Notes: Works pretty well in quick test but with Pen non-responsive and wireless only 24mbps (vs. 120 wired) didn't test very much. Works well as a WinXP/Win7 Tablet but would be better to get full functioning of Linux but still need to figure out how to get Pen working (see BitJam's suggestion) and upgrade Wireless card (and possibly need standard BIOS fix to get it to accept the card). Best highest resolution Tablet screen ever, so real shame pen doesn't work with MX-15. Only bother testing further if can get pen working otherwise other distros for this one.

x200t (7450-9RU) 2010-01 (CPU: Core2 Duo L9600 2.13GHz, RAM: 8GB, VRAM:?)

  • Notes: Pen non-responsive like x61t but wireless (90/120mbps) is actually ok! Looks like works OK with MX-15.b2 except for pen but without that not much point using it. Only bother testing further if can get pen working on x61t otherwise other distros for this one.

x301 (4057-WXP) 2010-02 (CPU: Core2 Duo U9600 1.6 GHz, RAM: 8GB, VRAM:?)

  • Notes: Really disappointing and inexplicable MX-15.b2 DVD Boot Fail (after it works perfectly with LinuxLite 2.6, for example) despite massive help from BitJam nothing worked (have a few desperate long shots to try if have time but little hope), however USB worked OK, and mSATA physical transfer was also OK. Wireless OK (70/120mbps). Try again with RC1 to see if miraculously fixed DVD install (to mSATA on Aleratec Adapter), might even try external DVD install, ... If not USB install should fine. One of the best “chest-top” couch- browsing computer, hope to get it working right with RC-1 or final, if not also maybe try Debian 9 “Stretch” alpha test dvd again to see if dvd might work with MX-16 in future.

W500

  • Notes: MX-14.4 and MX-15.b2 32-bit work! :) but MX-15.b2 64-bit is a dismal failure! :( Apparently, this is a known Radeon/Debian problem (LinuxLite 2.6 works fine, for example), maybe also test with Debian 9 “Stretch” Alpha to compare and see if hope for future of MX-16 with this.

W700 (2752-RZ2) 2009-03 (CPU: Core2 Duo T9600 2.8GHz, RAM:8GB, VRAM:1GB!)

  • Notes: Looks like it works fine with MX-15.b2 x64-bit but didn't do much testing, wait to see how changed RC-1 does 64-bit... Also, see if can figure out how LinuxLite 2.6 gets an NVidia-specific driver working and see if Debian/MX can do this too, test to see if getting full value out of graphics card. Again, more to test once 64-bit MX-15.rc1 comes out...

W701 (2500-3BU) 2010-08 (CPU: Core i7 Q 820 1.73GHz x8 threads!, RAM: 32GB ! , VRAM:1GB!).

  • Notes: much like W700 (above). Surprisingly, given the x61t and x200t, the Pen works fine on the integrated Wacom pad! Check if Nvida like W700 for LinuxLite 2.6. Again, wait for MX-15.rc1 x64-bit fix to test. This massive Desktop Publishing Powerhouse Workstation would be great to get running and see if Linux can match Win7 which this flies on (if it can then it'll be up to software, Adobe PhotoShop/Illustrator/InDesign vs. Gimp/Inkscape/Scribus, to see if I even need Windows for anything but games) ... Hoping for MX15.x x64-bit changes are OK with this...

x220 and 220t (4298-A16) 2012-02 (CPU: Intel Core i7-2620M 2.7GHz/3.4GHz, RAM:16GB!)

  • Notes: Pen actually works on this Tablet (unlike x61t and x200t), looks like latest/fastest tablet will work well, with MX-15, but still waiting on x64-bit changes for MX-15.rc1+ before really testing...

W520 (4276-23U) 2011-05 (CPU:i7-2820QM 2.3GHz/3.4GHz, RAM:32GB!, VRAM:2GB!)

  • Notes: My Newest, fastest, best, last, most future-proof computer (best RAM and Graphics of any computer I own, and better than or equal to many of even the new+upcoming Thinkpads), so looking forward to seeing what Linux can do on the high-end hardware for gaming (e.g., Steam and Wine games not sure about Linux) and mapping software that are fast in Win7.

v. 20160111

Comments

Thinkpad T550

m_pav's picture

Rating - 8.5 / 10

Stock MX-15 64-bit loads and runs reasonably well, but machine is unstable with the stock 4.2 kernel resulting in frequent hard locks due to the Intel Broadwell-U Integrated Graphics. Machine stabilises somewhat with the latest kernels from Debian Backports or the 4.6 Liquorix kernel, but still suffers hard lockups when viewing multimedia content, esp through facebook and Google Chrome, though not limited to Chrome, same crash in FF. Apart from the crashes, almost everything else works very well, though I've had the randon loss of individual USB3.0 ports from time to time, no pattern or reason I can pinpoint. Putting the machine to sleep and waking it again causes the lockups to increase dramatically, but a clean reboot sorts it all out. Battery drain during sleep is better than Windows OOTB, 7 days and discharged to 39%.

System:    Host: Mikepav Kernel: 4.6-1.dmz.1-liquorix-amd64 x86_64 (64 bit gcc: 4.9.2)
           Desktop: Xfce 4.12.2 (Gtk 2.24.25) Distro: MX-15_x64 Fusion 06 January 2016
Machine:   System: LENOVO (portable) product: 20CK0011AU v: ThinkPad T550
           Mobo: LENOVO model: 20CK0011AU v: SDK0E50510 WIN Bios: LENOVO v: N11ET31W (1.07 ) date: 03/19/2015
Battery    BAT0: charge: 40.0 Wh 95.6% condition: 41.9/44.4 Wh (94%) model: SANYO 45N1741 status: Discharging
           BAT1: charge: 20.1 Wh 99.2% condition: 20.3/23.2 Wh (87%) model: SANYO 45N1775 status: N/A
CPU:       Dual core Intel Core i7-5600U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10375
           clock speeds: max: 2601 MHz 1: 1200 MHz 2: 1100 MHz 3: 500 MHz 4: 500 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.05hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 11.1.3 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.6-1.dmz.1-liquorix-amd64
Network:   Card-1: Intel Ethernet Connection (3) I218-LM driver: e1000e v: 3.2.6-k port: 3080 bus-ID: 00:19.0
           IF: eth0 state: down mac: 54:ee:75:4e:fe:df
           Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 03:00.0
           IF: wlan0 state: up mac: 34:02:86:08:9d:af
Drives:    HDD Total Size: 1128.2GB (61.9% used) ID-1: /dev/sda model: WDC_WD10SPCX size: 1000.2GB
           ID-2: /dev/sdb model: ADATA_SP600NS34 size: 128.0GB
Partition: ID-1: / size: 22G used: 6.5G (33%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 773G used: 448G (61%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 29.5C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 231 Uptime: 10 min Memory: 937.6/15771.7MB Init: SysVinit runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.3.0